Customer Portal Log in Issues
Incident Report for Equinix Metal
Resolved
This incident has been resolved.
Posted Oct 02, 2023 - 11:45 UTC
Investigating
Our engineering team is currently investigating an issue where customers are unable to log into the customer portal.

Please reach out to support@equinixmetal.com with any questions.
Posted Oct 02, 2023 - 05:25 UTC
This incident affected: Equinix Metal Portal.