Equinix Metal Portal Impact
Incident Report for Equinix Metal
Resolved
This incident has been resolved.
Posted Oct 30, 2024 - 13:09 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 30, 2024 - 01:52 UTC
Investigating
We are currently experiencing an issue affecting the Equinix Metal customer portal when deleting interconnections. Please bear with us while we address this issue.

Please visit status.equinixmetal.com for further updates or reach out to support@equinixmetal.com for further assistance.
Posted Oct 29, 2024 - 21:19 UTC
This incident affected: Equinix Metal Portal.