All services remain stable and the the issue is deemed resolved. Root cause analysis is ongoing.
Posted Oct 21, 2025 - 15:03 UTC
Monitoring
All services remain stable. There has been confirmed mixed impact to Internet and interconnection services in multiple metros. The estimated period of impact is 1032-1047 UTC.
Connectivity is confirmed stable since 1046 UTC. There was a major event in the Equinix backbone network which is being investigated as part of a larger global incident.
Posted Oct 21, 2025 - 12:43 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 21, 2025 - 11:27 UTC
Investigating
We are currently investigating a connectivity issue affecting stability in NY Metro.
Please visit status.equinixmetal.com for further updates or reach out to support@equinixmetal.com for further assistance.
Posted Oct 21, 2025 - 10:59 UTC
This incident affected: Americas (New York (NY)) and Equinix Metal Network.